Jump to content


Photo
- - - - -

settings up IIS on windows xp home.


  • Please log in to reply
3 replies to this topic

#1 binary

binary

    Sarcastic

  • ++Member
  • 224 posts
  • Location:London
  • Interests:Unreality -?

  • United Kingdom

Posted 02 September 2004 - 09:22 PM

for all you people who know what IIS is, you will know that it cannot be run on windows xp home edition , as standard this will show you how to set up IIS on your version of xp home!
for those of you who do not know what IIS is, it is Internet information server and you will need this if you want to set up a server on your home computer if you are running windows xp home edition.


How to enable personal web sharing in Windows XP Home Edition. [via 4 Guys From Rolla ASP FAQ, via Poochkiss, 2/23/2002]Microsoft has discontinued the Personal Web Sharing product that came with Windows 95/98/ME, and IIS is only included in the Professional Edition. Furthermore, they appear to have gone to some length to keep you from installing it manually.

Here’s what you have to do to set up a web server on Windows XP Home Edition:

open C:WINDOWSINFSYSOC.INF in Notepad or another text editor

locate a section called [Components]

find a line like this: iis=iis.dll,OcEntry,iis.inf,hide,7

change it to this: iis=iis2.dll,OcEntry,iis2.inf,,7

Copy IIS.DL_ and IIS.IN_ from the Windows 2000 Advanced Server CD (according to this thread on devdex, Windows 2000 Professional CD also works, but the Professional Edition of XP does not)

From a command prompt, EXPAND IIS.DL_ IIS2.DLL

Copy IIS2.DLL to C:WINDOWSSYSTEM32SETUP

From a command prompt, EXPAND IIS.IN_ IIS2.INF

Copy IIS2.INF to C:WINDOWSINF

Now you can start installing it. Go to Start menu, Settings, Control Panel, Add/Remove Programs, Add New Programs, select IIS.

When prompted for files, alternately insert your XP Home Edition CD or the Advanced Server CD. You will have to manually search for each file on each CD; it doesn’t know the correct path for any of them. Some files (like INFOCTRS.DLL) are not on either CD, but they are stored in compressed form in C:WINDOWSI386. Select the compressed file (like INFOCTRS.DL_) and the installer will uncompress it and continue.

Reboot



You will still have to go to IIS Administration (Start menu, Settings, Control Panel, Administrative Programs, IIS) and set up virtual directories (right-click on Default Site and select “New virtual directory", then step through all the tabs to configure it). Also (and I’m not clear on this step), you’ll need to go to the Directory Security tab, click Edit, and browse for the user setup on your computer. If you have multiple users on the machine, you would presumably have to set up separate virtual directories for each of them and set privileges manually in order to allow each user to administer their own virtual site. If anyone has actually succeeded in doing this, please let me know.

By contrast, here’s what you have to do to set up a web server on Mac OS X:

Go to Apple menu, System Preferences, Sharing.

Under Web Sharing, click Start.



Every user now has their own web site, served by Apache. Each user can put files and folders in the Sites folder of their home directory, and they will be served up from http://localhost/~username/. Users can only edit their own site (though of course they can browse other users’ sites in a web browser). Administrators can also put files and folders in /Library/WebServer/Documents/, and they will be served up from http://localhost/.



#2 amir

amir

    SuperNova III Member

  • Support Team
  • 2,141 posts
  • Location:Toronto
  • Interests:http://adagio.fm<br />http://entranced.fm/

  • Canada

Posted 03 September 2004 - 06:29 AM

Isn't it illegal? Stealling IIS from Win2000 :D

#3 binary

binary

    Sarcastic

  • ++Member
  • 224 posts
  • Location:London
  • Interests:Unreality -?

  • United Kingdom

Posted 03 September 2004 - 09:20 PM

:ph34r: dont think so , its just not "as standard"
i got it running pretty sweet , especially the IIS for asp.net with visual studio

#4 shiral

shiral

    New Member

  • Members
  • Pip
  • 1 posts

  • Australia

Posted 31 October 2007 - 01:45 AM

Hi,

I tried all this, and i can now see the option in the Windows Components. But i can't seem to tick the option, the option even gets highlighed, but i can't tick it to go next. :'(

Shiral.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users